HostMonster Web Hosting Help

Addons incompatible with php 5.4

With the deprecation of php 5.2 and 5.3, HostMonster has chosen to update all of our shared servers to php 5.4. If you find that one of your plugins, themes, or other addons are not working it is recommended that you check your WordPress Dashboard under the Updates section to see if there is an update available, if none are you will want to contact the developer of the addon for an updated addon. While most of the developers have been quick to address incompatibles with current software, some addons are still incompatible with php 5.4. In these cases we have found the following manual fixes.

Incompatible Plugins

Platform Plugin Support Forum Fix
WordPress Instapress Link Yes
WordPressGTranslate Link Yes
WordPress SEO-Content-Control Link Yes
Drupal Google Analytics Tokenizer Link Yes
Drupal PathAuto Link Yes
Vbulletin Version 4.x Link Yes

Please note that HostMonster does not provide support for the above fixes, nor guarantee they will work. They are fixes created by the community and supported by the community.

Incompatible Themes

Platform Theme Support Forum Fix
WordPress Teardrop Link NA

Please note that HostMonster does not provide support for the above fixes, nor guarantee they will work. They are fixes created by the community and supported by the community.

Knowledgebase Article 42,475 views bookmark tags: php (updated 71 days ago)


Was this resource helpful?

Did this resolve your issue?


Please add any other comments or suggestions about this content:





Recommended Help Content

I'm trying to configure an application (phpList) and it requires that I enter (in config.php) a username and password for a POP3 account to handle bounces. I keep getting a POP3 error and it can't log (updated 1672 days ago)
Knowledgebase Article 61,226 views tags: list mail php phplist

How do I enable PHP 5 for my PHP applications? How do I change to PHP FastCGI? How do I use a single php.ini file? (updated 231 days ago)
Knowledgebase Article 129,699 views tags: config php

PHP vs PHP single php.ini vs PHP with FastCGI (updated 705 days ago)
Knowledgebase Article 109,364 views tags: configuration php server

Related Help Content

SMTP fails when sending through mailing list (e.g. Mailman, Dadamail, phpList), but no error logs are generated. (updated 965 days ago)
Knowledgebase Article 68,751 views tags: dada list mail mailing mailman mta phplist smtp

How do I change the PHP environment for my site with php.ini? (updated 260 days ago)
Knowledgebase Article 254,864 views tags: configuration php server

Can I export my mailing list from Mailman? (updated 642 days ago)
Knowledgebase Article 60,189 views tags: export list mailing mailman

In the newer versions of PHP, they have included a new directive to control and handle remote includes. We disable this option, by default, which may affect some of your PHP scripts. (updated 1625 days ago)
Knowledgebase Article 50,720 views tags: php remote url

This article will outline which PHP PEAR Packages are installed and how you can install additional PHP PEAR Packages. (updated 192 days ago)
Knowledgebase Article 52,871 views tags: package pear php

When creating a symlink to a php page, I get a 500 error. I am able to use symlinks to other files and folders fine. (updated 1414 days ago)
Knowledgebase Article 46,846 views tags: link php

How can I adjust the php settings specifically for an Addon Domain? (updated 643 days ago)
Knowledgebase Article 88,459 views tags: domain php

Using PHP on HostMonster.com (updated 1645 days ago)
Knowledgebase Article 63,830 views tags: php